Follow

What are the minimum system requirements?

History.com has been designed to run on the most popular platforms and web browsers. To fully enjoy this service, we recommend all users have the following:

  1. Windows XP or above; Mac OS 10.4, and above
  2. Web browser for Windows: Internet Explorer 9 or higher, Firefox 12.0 or higher Google Chrome 26.0 or higher
  3. Web browser for Mac: Safari 5.0 or higher, Firefox 12.0 or higher, Google Chrome 26.0 or higher
  4. Adobe Flash Player 10 (Available here: http://www.adobe.com/support/flashplayer/downloads.html)
  5. JavaScript should be enabled
  6. High-speed Internet connection.
  7. Some pages and/or features may appear as a pop-up. We ask that you monitor your pop-up blocker if you do not see a page appearing when you click on a link.
Was this article helpful?
1 out of 3 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk